Conditions of use

Intended use

Wizard 5 is a PC based configuration tool intended to provide access to programmable settings of the control system, enabling customisation of driving parameters and performance to suit the needs and preferences of individual users.

Warnings

Performance adjustments must only be made by healthcare professionals, or by persons who completely understand the programming parameters, the adjustment process, the configuration of the vehicle, and the capabilities of the driver.

Inappropriate settings can make the vehicle uncontrollable or unstable. An uncontrollable or unstable vehicle can cause an unsafe situation such as a crash, with the risk of serious injury to the driver or bystanders, or damage to the vehicle or surrounding property.

After you have programmed the vehicle, test the vehicle thoroughly according to the testing procedure for the control system that is installed on the vehicle, as described in the relevant installation manual(s). Check that the vehicle drives safely and that the performance of the vehicle is appropriate to the capabilities and needs of the user. If the vehicle does not perform as intended, reprogram the vehicle and test again. Repeat this procedure until the vehicle performs as intended. If the intended performance cannot be reached, contact your service agent.

It is the responsibility of the health care professional to make sure that the user is capable of understanding and physically operating the programmed features and functions.

With inappropriate programming settings, certain features and options may not be accessible or perform as expected.

While the programming tool is writing a program to the vehicle,

- if the programming tool is disconnected from the vehicle, or
- you abort the download manually, or
- the programming tool indicates “Failed” or “Disconnected”, or
- the PC is turned off or crashes,

then the download is not complete and the vehicle cannot be used. Make sure that a new download is completed successfully before the vehicle is used.

After the program is successfully written to the vehicle, read the program back from the vehicle to check that the program in the control system has the correct values.

Disclaimer

Dynamic Controls accepts no liability for any loss sustained through inappropriate programming or use by unqualified personnel.

Failure to comply with these requirements will render Dynamic Controls free of all liability.

Copyright

Wizard 5 is copyrighted - no portion of this software may be reproduced in any form without prior written permission of Dynamic Controls. Unauthorised use, reproduction or distribution will be grounds for prosecution.
# Contents

## Conditions of use ................................................................. 3

## Contents ............................................................................. 4

### 1 Introduction to the Wizard .................................................... 7

1.1 Features ............................................................................ 7
1.2 What You Need .................................................................. 8
   1.2.1 The Software .................................................................. 8
   1.2.2 The Cables .................................................................. 9
     1.2.2.1 DX programming cable .......................................... 9
     1.2.2.2 USB to COM converter cable .................................... 9
   1.2.3 The Adaptors .................................................................. 9
   1.2.4 The Dongle ................................................................ 10

### 2 Installation ........................................................................... 11

2.1 USB converter cable installation - Windows XP ...................... 11
   2.1.1 Determine the COM port number of the USB cable .......... 13
   2.1.2 Change the COM port number of the USB cable ............ 14
2.2 Wizard software installation - Windows XP ............................ 15
2.3 Windows Vista Installation Notes .......................................... 17
   2.3.1 Border issues with Windows Vista default theme .......... 17
   2.3.2 Enabling Wizard Internet update in Windows Vista ........ 17
2.4 Preparation to start Wizard for the first time ......................... 18
2.5 Start the Wizard .................................................................. 18
2.6 Configure the Wizard (Dongle, COM port) ............................ 19
2.7 Update the Wizard .............................................................. 20

### 3 Getting Started .................................................................... 21

3.1 The main screen .................................................................. 21
3.2 The command buttons ......................................................... 21
3.3 Terminology ....................................................................... 22
   3.3.1 Parameters ................................................................ 22
   3.3.2 Program ..................................................................... 22
   3.3.3 Template ................................................................... 22
3.4 Standard procedure ............................................................ 22
3.5 Connect to a controller ......................................................... 23
3.6 Open an existing program for the controller ......................... 24
3.7 Create a new program yourself (DX/DX2 only) .................... 25
3.8 Save a loaded program to a file .......................................... 28
3.9 Read a program from the controller .................................... 29
3.10 Write a loaded program to a controller ............................... 30
3.11 Read diagnostic data from the controller ............................ 31

### 4 Plug-ins ............................................................................... 33

4.1 HHP Emulator ................................................................. 33
4.2 DX2 Power Module Load Compensation .............................. 34
4.3 DX2 Power Module Service Data Manager .......................... 35
   4.3.1 Service Scheduler ..................................................... 35
4.3.1.1 Service Schedule Type ........................................ 35
4.3.1.2 Last service date ........................................ 36
4.3.1.3 Time since last service .................................. 36
4.3.1.4 Service schedule due at ................................. 36
4.3.1.5 Time to next service .................................... 36

4.3.2 Chair Data ...................................................... 37
4.3.2.1 Drive Time ................................................. 37
4.3.2.2 Drive Cycles .............................................. 37
4.3.2.3 Power On Time ......................................... 37
4.3.2.4 Power Cycles ............................................ 37
4.3.2.5 Power On Cycles ........................................ 37
4.3.2.6 Power Off Cycles ....................................... 37

4.3.3 Battery Data .................................................... 38
4.3.3.1 Battery Capacity History ................................. 38
4.3.3.2 Overcharge Cycles ...................................... 38
4.3.3.3 Overcharge Time ....................................... 39
4.3.3.4 Charge Time ............................................ 39
4.3.3.5 High-load Discharge Time .............................. 39

5 Troubleshooting ..................................................... 40
5.1 Controller not detected ........................................ 40
5.2 Not able to read from controller ............................... 40
5.3 Not able to write to controller ................................. 40
1 Introduction to the Wizard

1.1 Features

Wizard is a PC Software programming tool that:

- Can edit, read, write and store powerchair and scooter programs from/to DYNAMIC controllers
- Can read diagnostic reports from DYNAMIC controllers
- Is intended for manufacturers, dealers and therapists
- Runs under Microsoft Windows 2000, XP and Vista
1.2 What You Need

- A PC running Microsoft Windows 2000, XP or Vista. The hardware specifications of the PC must be equal to or better than the recommended system requirements of your operating system.
- The Wizard PC Software - installs on your PC.
- A USB to COM converter if your computer does not have a COM port.
- A programming cable - connects to the controller.
- An adaptor if your controller does not have a Hirose programming socket.
- A dongle - determines parameter access.

Note:

Do not use processor intensive applications while running the Wizard S.

Do not switch off the PC without exiting from the Wizard S first.

1.2.1 The Software

Available on CD:
Order Number DWIZ-SW

Available for download on the web site:
http://www.dynamiccontrols.com/index.cfm/1,150,372,html

The web site also has tutorials and manuals available on the same download page.

Available as kit:
CD + USB converter + Programming cable + DWIZ-ADAPT

Order number DWIZ-KIT

Note:

Install the drivers for the USB converter cable before you install the Wizard.
See section 2.1 for installation instructions of the USB converter cable.

See section 2.2 for installation instructions of the Wizard.
1.2.2 The Cables

1.2.2.1 DX programming cable
The DX programming cable connects the computer to the controller.
Order Number DWIZ-CABLE

The cable connects directly to all controllers that have a Hirose programming socket (DX and Rhino). For other controllers (DX2, Shark, A-series, R-series, RHINO2 and DL) an adaptor is needed (see 1.2.3).

The DX programming cable connects directly to the COM port of the computer. If your computer does not have a COM port, you need a USB to COM converter cable.

1.2.2.2 USB to COM converter cable
The USB to COM converter cable connects the DX Programming cable to an USB port of the computer.
Order Number DX-USB-COM

<table>
<thead>
<tr>
<th>Note:</th>
</tr>
</thead>
</table>
| Install the drivers for this cable before you install the Wizard software.  
See section 2.1 for installation instructions. |

If you use the USB to COM converter cable, disconnect high bandwidth USB devices from the computer while you use the Wizard 5. High bandwidth USB devices include, for example: all speakers, microphones, video cameras and still cameras that have a USB cable to connect them to the computer.

1.2.3 The Adaptors
The adaptors connect the DX programming cable to the controllers that do not have a Hirose connector.

<table>
<thead>
<tr>
<th>Order number</th>
<th>Connects to</th>
</tr>
</thead>
<tbody>
<tr>
<td>DWIZ-ADAPT</td>
<td>DX2, Shark (Wizard only), A-series, RHINO2, R-series (XLR)</td>
</tr>
<tr>
<td>DK-ADAPT</td>
<td>Shark (Wizard + HHP)</td>
</tr>
<tr>
<td>DR-PRGLM02</td>
<td>R-series, RHINO2 (Molex)</td>
</tr>
<tr>
<td>DL-ADAPT</td>
<td>DL</td>
</tr>
</tbody>
</table>

The DWIZ-ADAPT is also included in the DWIZ-KIT. Order the other adaptors separately.
1.2.4 The Dongle

The Wizard needs a dongle to program a controller.

Without a dongle, it is still possible to read a program from a controller or to create a diagnostic report, but it is not possible to write anything to a controller.

The dongle type defines which parameters can be viewed and adjusted.

<table>
<thead>
<tr>
<th>Dongle Type</th>
<th>Wizard name</th>
<th>Gives access to</th>
<th>Order number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dealer</td>
<td>Lite</td>
<td>Drive Performance&lt;br&gt;End user tuning only</td>
<td>DWD-DLR-U</td>
</tr>
<tr>
<td>Enhanced Dealer</td>
<td>Standard</td>
<td>Drive + seating changes&lt;br&gt;Customise &amp; Configuration</td>
<td>DWD-EDL-U</td>
</tr>
<tr>
<td>OEM</td>
<td>Advanced</td>
<td>Full chair set up&lt;br&gt;Design &amp; Configuration</td>
<td>DWD-OEM-U</td>
</tr>
<tr>
<td>Factory</td>
<td>Write</td>
<td>View and write only,&lt;br&gt;no adjustments possible</td>
<td>DWD-FAC-U</td>
</tr>
</tbody>
</table>

See the installation manual of your controller for more information on which parameters are visible and/or editable at which level.

For information on how to change the dongle level in the Wizard, see section 2.6.

**Note:**

Each dongle has a serial number. The serial number of the dongle is stored in the controller when the Wizard writes a program to the controller.

This way it is always possible to check who programmed a controller.
2 Installation

2.1 USB converter cable installation - Windows XP

1. Insert the install CD into the CD drive

2. Insert the USB connector of the cable into the USB port of your computer

If Windows asks you if you want to connect to Windows update:

3. → No, not this time
4. → Next

5. → Install the software automatically
6. → Next
7. → Finish

If Windows asks you if you want to connect to Windows update:

8. → No, not this time
9. → Next

10. → Install the software automatically
11. → Next

12. → Finish
2.1.1 Determine the COM port number of the USB cable

The Wizard needs to know the COM port number of the DX-USB-COM.

13. → Start
14. Right-click on My Computer
15. → Properties
16. → Hardware
17. → Device Manager

18. → ‘+’ Ports (COM & LPT)
19. USB Serial Port (COM#)

- Use this value in the Wizard installation.
- If you want to change the COM port number: go to step 20.
- If you do not want to change the COM port number: go to step 26.
2.1.2 Change the COM port number of the USB cable

20. → Double click on **USB Serial Port**
21. → **Port Settings**
22. → **Advanced**

23. → Select the desired COM port (Wizard 3.5 only works with COM1 or COM2, Wizard 5 works with COM1 to COM9).
   **Note:** do not select a port number that shows **(in use)**.

24. → **OK**
25. → **X**
26. → **X**
27. ☺

The USB-Serial converter is manufactured by Future Technology Devices. If you cannot install the device, please visit the manufacturer’s web site to download the latest drivers. Drivers for the USB-Serial converter can be found on the following page:

http://www.ftdichip.com/Drivers/VCP.htm

For Windows 2000, Windows XP and Windows Vista the **setup executable** link (in the Comments column) offers the easiest way to install the drivers.

Dynamic Controls accepts no liability for the use of 3rd party drivers on your computer.
2.2 Wizard software installation - Windows XP

1. If a previous version of Wizard 5 is already installed on your computer, backup your existing Wizard databases and programs before you install Wizard 5. In a standard install, the databases and programs are located in the folders C:\Wizard5\MDB and C:\Wizard5\Programs.

2. Double-click on Wizard5.x.xInstaller_0xx.exe (x and xx are version numbers)

3. → Yes

If a previous version of Wizard 5 is already installed on your computer, the installer asks if it is OK to overwrite the older version.

4. → Yes

5. → Next

6. If you want to have a Wizard icon on your desktop, click the checkbox

7. → Next

8. Choose the folder where the Wizard will be installed. If you do not know, the default folder that is already filled in will work fine.

9. → Next
10. **→ Install**

11. Wait until the progress bar is full

The installer will now install the dongle drivers (these drivers are called the HASP drivers). Make sure that there are no dongles connected to your computer.

12. **→ OK**

13. Wait during this window. This can take a long time, up to several minutes.

14. **→ Finish**
2.3 Windows Vista Installation Notes

For successful operation of Wizard 5 in Windows Vista, the following adjustments can be made if so desired:

- Screen adjustment to resolve border display issues
- Adjustment of "User Account Control" for simple operation of Wizard web updates

2.3.1 Border issues with Windows Vista default theme

You may observe difficulties with the last option in drop-down boxes being obscured by the border introduced with the default Windows Vista theme. To resolve this issue:

1. Start → Control Panel
2. Click the Customize Colors hyperlink under the Appearance and Personalization main heading.
3. Click Open Classic appearance properties... link at the bottom of page.
4. Click the Advanced... box in the bottom right of the window that appears.
5. Select the Border Padding option under the Item: drop option menu.
6. Set the size parameter to 1.
7. → OK

2.3.2 Enabling Wizard Internet update in Windows Vista

To start Wizard update, click Help → Check Internet for Updates. For instructions see section 2.7: Update the Wizard.

The update process only works within Vista if "User Account Control" (UAC) is disabled.

1. Log in with an account that has administrator privileges
2. Click Start → Control Panel
3. In the search box type UAC
4. Select the option Turn User Account Control On or Off (Turn it off)
5. Restart Vista.
6. Start the Wizard and update the databases (click Help → Check web for updates)
7. If desired, use steps 1 and 2 to turn UAC back on.

Note:

It is recommended that UAC is re-enabled after the update process to maintain the benefits of Windows Vista additional security.
2.4 Preparation to start Wizard for the first time

1. Connect the dongle to the PC
2. Connect the Wizard communication cable to a COM port of the PC, or to the USB converter cable
3. If you use a USB converter cable, connect the cable to a USB port of the PC
4. Connect the communication cable to the controller (with adaptor if applicable)
5. Turn on the controller

2.5 Start the Wizard

6. Start up the Wizard:
   - Start ➔ All Programs ➔ Dynamic Wizard 5 ➔ Wizard 5

7. Read the Warnings and Conditions of Use.
8. If you agree to the Conditions of Use, click I Accept

If your dongle has a password:
9. Enter the password
10. OK
2.6 Configure the Wizard (Dongle, COM port)

11. **Tools → Options**

12. **View Mode**

13. Select your dongle access level:
   - OEM → **Advanced**
   - Enh. Dealer → **Standard**
   - Dealer → **Lite**
   - Factory → **Write**

14. **Communications Port**

15. Select the COM port that you have connected the communication cable to. If you use a USB converter cable you can see which port the USB cable uses with the procedure described in section 2.1.1: Determine the COM port number of the USB cable.

16. **OK**

17. Wait 20 seconds. Check that the Status Window shows **Controller connected** and that the connection status is green.

18. If the Wizard cannot connect to the controller, repeat step 11, 14, 15 and 16 to choose another communications port and try again. See also section 3.5: Connect to a controller.
2.7 Update the Wizard

To make sure that your Wizard uses the latest information for your controllers, update the Wizard through the Internet.

Vista users must disable UAC temporarily to use web updates. See also section 2.3.2: Enabling Wizard Internet update in Windows Vista.

19. → Help → Check Internet for Updates

20. Wait until the progress bar is full

If the Wizard already has the latest information, it shows "All versions current".

21. → OK (aborts the update, the steps below are skipped)

If the Wizard does NOT have the latest information, it shows the files that must be updated.

22. → Download All

The Wizard must restart for the updates to take effect.

23. Click → Yes to restart the Wizard

24. Wait until the files have been downloaded. The Wizard will restart automatically.

To check the versions of your installed files, click Help → About.
3 Getting Started

3.1 The main screen

Note:
The dongle level determines which parameters can be seen and/or edited.

See section 1.2.4 (The Dongle) for more information about dongle levels.
See the installation manual of your controller for more information on which parameters are visible and/or editable at which level.
3.3 Terminology

3.3.1 Parameters
Adjustable items that define the behaviour of the
chair/scooter (vehicle).

3.3.2 Program
A file that contains the complete configuration
of a specific vehicle, including all parameter values.
This defines how the vehicle will operate.

3.3.3 Template
- Predefined programs with default settings for a specific
  system, located in the Wizard5\Programs folder.
- A new program that was created with
  File -> New Template (see section 3.7)

Warning:
A template is not a finished vehicle program. A template contains default settings
that are meant as a starting point to program the vehicle. The default settings are
probably not all suitable for your specific vehicle. In certain circumstances, the
vehicle may even be unsafe if a template is used to program the vehicle directly.
Always program and test the vehicle according to the programming/testing
instructions of the installation manual of your controller.

3.4 Standard procedure
- Open/create a program for your vehicle configuration, or, if you want to adjust an
  existing vehicle, read the program from the controller.
- Adjust the parameters of the program to suit a particular vehicle setup or user.
- Save the program for later reference/recovery.
- Write the program to the controller.
- Test that the vehicle performs as you expect.
  For the correct testing procedure, see the installation manual of your controller.
3.5 Connect to a controller

If the Wizard is **not connected** to a controller:

- Connect the controller to the computer (see also 1.2)

  ![Diagram showing PC, USB to COM converter, Programming cable, Adaptor, and Controller]

  **Precaution:**

  Make sure that the vehicle is not electro statically charged when you connect the controller to the PC, otherwise the PC may be damaged. To discharge the vehicle, touch a metal surface of the chair while standing on the ground.

- Turn on the controller

If the Wizard detects the controller and **successfully connects** to it:

  ![Diagram showing Controller and diagnostic buttons are grey]

  ![Diagram showing Read and diagnostic buttons are active]

  ![Diagram showing After a successful connection, the action field shows "Idle"]

If the Wizard **does not detect** the connected controller:

- Check that the controller is actually on.
- A communication error may have occurred; turn the controller off and back on.
- Check that you use the correct adaptor (1.2.3).
- DX / Rhino: check that you connect to the correct Hirose programming socket and not the XLR charger socket. DX / Rhino systems do not use an adaptor.
- Check that the software of the USB to COM converter is installed correctly (2.1).
- Check that the COM port that the Wizard uses (2.6) is the same COM port that the USB converter cable uses (2.1.1).
- Controller may be faulty: connect Wizard to another identical controller to check.
- PC/Cable/Adaptor may be faulty: connect controller to another PC/cable/adaptor.
3.6 Open an existing program for the controller

If a program file is available for your controller:

- Click on the blue “Open File” button, or use the menu: **File -> Open**
- Select the program to open
- Click on **Open**

The parameters of the program are shown on the screen.

**Note:**

In the **Wizard5\Programs** folder, you can find templates for most DYNAMIC controllers.

For DX2, no templates are available. Instead, you can create a new template yourself. Choose all the modules in your system from a list and optionally import settings from other files. See section 3.7 for instructions.

**Warning:**

Some parameters that are critical for the safety and stability of the vehicle cannot be changed when a dealer dongle or an enhanced dealer dongle is used (for dongle types see section 1.2.4).

Therefore, if you have a dealer dongle or an enhanced dealer dongle, make sure that the program you use is specifically designed for your vehicle by the vehicle manufacturer. Any other program, including the templates provided in the **Wizard5\Programs** folder, can make the vehicle unsafe.
3.7 Create a new program yourself (DX/DX2 only)

**Warning:**

Some parameters that are critical for the safety and stability of the vehicle cannot be changed when a dealer dongle or an enhanced dealer dongle is used (for dongle types see section 1.2.4).

Therefore, only use this feature if you have an OEM dongle. If you have a lower level dongle, only use this feature if you can import parameters from a program that was specifically designed for your vehicle by the vehicle manufacturer.

Using a program with only the default values as created by this feature can make the vehicle unsafe in certain circumstances.

- Choose the menu command
  **File -> New Template**

- Select your system configuration

  The system description provides more information about the selected configuration

- Click **Next**
For each module of the chosen configuration, select the correct module type from the list.

The module description provides details about the selected module type.

- Click **Next**

The selection history shows all the modules you have selected so far.

After you have selected all the modules, this screen shows an overview of your chosen system configuration.

- If you want to import parameter values from an existing DX or DX2 program, click **Import settings from file**

- Otherwise, click **OK** to create the program

**Import Settings**

- Select the DX/DX2 program file to copy parameters from

- Click **Open**
Select all the parameters that you want to copy from the selected file into your new program.

When you are ready, click on **Import**.

After you have copied the parameters, you return to the selection overview.

Parameter import is added to the selection history.

If you want to import more parameter values from another file, click again on **Import settings from file**.

Otherwise, click **OK** to create the program.

The parameters of the new program are shown on the screen.

Imported parameter values that are different from the default value are shown in blue.
3.8 Save a loaded program to a file

Note:
Save your program:
- before you adjust settings, to make sure you can go back to the original settings later
- after you have adjusted settings, to have backup programs for individual patients, individual clients, or individual chair designs

- Make sure that a program is loaded
- Enter a name in the Name parameter field before saving (for example, the name of the patient or the type of the chair) for easy identification later

- Click on the "Save Program" button

- Type the file name
- Click on Save
3.9 Read a program from the controller

- Connect the controller to the computer (see 3.5)

**Precaution:**

*Make sure that the vehicle is not electro statically charged when you connect the controller to the PC, otherwise the PC may be damaged. To discharge the vehicle, touch a metal surface of the chair while standing on the ground.*

- Wait until the “Read from controller” button is green

- Click on the button

- Wait until the progress bar is full

The parameters of the program are shown on the screen

**Note:**

*The dongle level determines which parameters can be seen and/or edited. See section 1.2.4 (The Dongle) for more information about dongle levels. See the installation manual of your controller for more information on which parameter is visible and/or editable at which level.*

If the Wizard cannot read from the controller or does not show the parameters correctly:

- Your Wizard version may not support the connected controller - update the Wizard (2.7).
- The controller may have a software fault - check the controller diagnostics (3.11).
3.10 Write a loaded program to a controller

- Make sure that a program is loaded
- Enter a name in the Name parameter field before writing (for example, the name of the patient or the type of the chair) for easy identification later
- Connect the controller to the computer (see 3.5)

**Precaution:**

Make sure that the vehicle is not electro statically charged when you connect the controller to the PC, otherwise the PC may be damaged. To discharge the vehicle, touch a metal surface of the chair while standing on the ground.

- Wait until the "Write to controller" button is red*

- Click on the button

- Wait until the progress bar is full

- Turn the controller off, wait 10 seconds, and turn the controller on

- For DX/DX2 systems, cycle the power a second time

**Note:**

The serial number of the connected dongle is stored in the controller when the Wizard writes a program to the controller.

This way it is always possible to check who programmed a controller.

*If the read button is green and the write button still does not become red:

- Was the dongle connected before the Wizard was started? If not, restart the Wizard.
- Check that the dongle is detected: Help → About. Dongle ID should not be zero.
- If not detected, download and install latest full Wizard version from the web site.
3.11 Read diagnostic data from the controller

- Connect the controller to the computer (see 3.5)

**Precaution:**

*Make sure that the vehicle is not electro statically charged when you connect the controller to the PC, otherwise the PC may be damaged. To discharge the vehicle, touch a metal surface of the chair while standing on the ground.*

- Wait until the “Read diagnostic” button is orange

- Click on the button

- Wait until the progress bar is full

The diagnostic data of the controller is shown on the screen

- To save the diagnostic data to a file, click on the “Save” button

To clear the fault log, click **Tools -> Erase Controller History**

This deletes the diagnostic data that is stored in the controller.
4 Plug-ins

The Wizard has several plug-in utilities for specific controllers.

To start a plug-in, click **Tools -> Plug Ins** and then choose the desired plug-in.

If a specific plug-in is not available in the menu, you can request the plug-in from Dynamic Controls. Copy the .dwp file of the plug-in to the **Wizard5\Plug Ins** folder. After restarting the Wizard the plug-in should be available.

4.1 HHP Emulator

This plug-in emulates the HHP. It can be used for training or in circumstances when the original HHP can cause problems or be extremely slow, especially
- DX-GB programming, and
- IRIS learning setup.

To start this plug-in, click **Tools -> Plug Ins -> HHP Emulation**.

If a communication fault occurs, click **Retry**.

If **Retry** does not restore the communication, close the plug-in, wait until the Wizard has connected to the controller again (the bottom right indicator goes green) and restart the plug-in.
4.2 DX2 Power Module Load Compensation

This plug-in can determine the Load Compensation value automatically on a powerchair that has a DX2 Power Module. To measure the motor resistance accurately, use the following procedure.

- Install and connect the complete DX System (Master Remote, Power module, motors, batteries) first
- Turn the system on and set the Load Compensation to 0
- Turn the system off and on to activate the new value
- Select a slow Drive Profile
- Lock or stall the wheels of the powerchair so that the wheels are not able to turn. For a reliable measurement, it is important that the motors are not able to move.
- Connect a computer to the DX System with a programming cable. Start the Wizard and wait until “controller connected” is shown in the status window
- Start the plug-in:
  Tools → Plug-ins → DX2 Power Module Load Compensation

- **Slowly** deflect the joystick in all directions until the motor current is at least 10 A for both motors. If the current is high enough, the bar of the current becomes green.

- Return the joystick to the centre.
  The calculated motor resistance is shown in the resistance fields.
- Lock the wheels in a different position and repeat the measurement.
- Perform the test when the motors are cold and when the motors are hot.
- Use the measurement with the lowest value. Decrease this value by 20% and set that as Load Compensation resistance with the Wizard.
- Test if the chair drives as expected.
  If the chair drives too soft or rolls back on a slope, increase Load Compensation, but NEVER increase it above the lowest measured value.
4.3 DX2 Power Module Service Data Manager

The Service Data Manager is a Wizard plug-in that
- controls the Service Scheduler of the DX2 Power Module
- shows detailed information on the usage of the powerchair and the state of the battery.

To start the Service Data Manager, connect the DX System to the computer, start the Wizard and click
Tools → Plug-ins → DX2 Power Module Service Data Manager.

Wait until the status bar shows Data Successfully Received.

The plug-in now shows up-to-date information.

4.3.1 Service Scheduler

With the service scheduler, the person who performs maintenance on the chair can program a suitable time at which the chair must be brought in for maintenance. After the set time has passed, the Master Remote indicates to the operator that the chair should be serviced, each time that the DX System is turned on.

**Note:**

*Only DX2 Master Remotes show a maintenance indication to the user.*
*A DX Master Remote does not communicate with the Service Scheduler and therefore takes no action.*

*It is however still possible to look at the Service Scheduler data with the Service data Manager when a DX Master Remote is installed.*

After a chair has received maintenance, the service technician can edit the parameters to set the correct servicing date and to set the Service Schedule Due At parameter to the correct value.

To save the new settings in the Power Module, click Write.

4.3.1.1 Service Schedule Type

**Off**  
- The Service Scheduler does not indicate to the user that the chair must be brought in for maintenance. All the chair usage data is still visible with the Service Data Manager, only the indication on the Master Remote is not shown.

**Drive Time**  
- The Service Scheduler indicates that the chair must be brought in for maintenance when the Drive Time (the total time that the joystick is deflected) in the ‘Chair Data’ section exceeds Service Schedule Due At (in hours). Use this setting for standard chairs that are used outdoors as well as at home.
Drive Cycles – The Service Scheduler indicates that the chair must be brought in for maintenance when the number of **Drive Cycles** (the number of times that the joystick is deflected and returned back to the centre) in the ‘Chair Data’ section exceeds **Service Schedule Due At** (in cycles). Use this setting for chairs that are mainly used at home, because the drive time remains relatively small while the parkbrakes, motors and joystick are used heavily for many small chair movements.

On Time – The Service Scheduler indicates that the chair must be brought in for maintenance when the **Power On Time** (the total time that the DX System has been turned on) in the ‘Chair Data’ section exceeds **Service Schedule Due At** (in hours). Use this setting for chairs where the drive time or drive cycles do not give an accurate measure for the wear of the chair, for example, chairs that have fragile movable structures that are used frequently when the chair is not driving.

### 4.3.1.2 Last service date

After a chair has received maintenance, the service technician can set the last service date to the current date. This way, another technician or a therapist can check when the last maintenance of the chair has occurred.

To save the new setting in the Power Module, click **Write**.

### 4.3.1.3 Time since last service

Dependent on the value of **Service Schedule Type**, this parameter shows the drive time, the drive cycles or the on time that has elapsed since the last maintenance of the chair.

The service technician should reset this value to zero after chair maintenance.

This parameter is only an indication for the therapist/technician and is not used in the Service Scheduler calculation.

### 4.3.1.4 Service schedule due at

The total drive time, on time, or number of drive cycles (dependent on the **Service Schedule Type**) after which the chair must receive maintenance. The service technician should set this parameter to the appropriate value for the chair, the driving style of the user and the terrain that the chair is used in.

If the value of **Drive Time**, **Drive Cycles** or **Power On Time** exceeds **Service schedule due at**, the Master Remote indicates to the operator that the chair should be serviced, each time that the DX System is turned on. To clear the indication, the service technician can either reset the Chair Data parameters to zero or increase the value of **Service Schedule Due At**, dependent on the way the chair data is used (see 4.3.2 for details).

If **Service Schedule Type** is set to ‘Off’, this parameter is ignored.

### 4.3.1.5 Time to next service

As an indication for the therapist/technician, this parameter shows the value of **Service Schedule Due At** minus **Drive Time/DriveCycles/Power On Time**.

This shows how much time/cycles are left before the Master Remote indicates that the chair should be serviced.
4.3.2 Chair Data

The chair data can be used in two different ways:

- A measurement of chair usage over the total life of the chair.
  In this case, the chair data should never be reset to zero. If the Power Module is ever replaced, write down the chair data values from the old Power Module, and use the Service Data Manager to write these values to the new power module (edit the values and click Write).

- A measurement of chair usage between maintenance dates. In this case the service technician should reset all these values to zero after chair maintenance (click Clear All and click Write).

4.3.2.1 Drive Time

The total time that the Power Module has released the parkbrakes to drive the chair.

4.3.2.2 Drive Cycles

The total number of times that the Power Module has released the parkbrakes to drive the chair.

4.3.2.3 Power On Time

The total time that the DX System has been turned on.

4.3.2.4 Power Cycles

The total number of times that the Power Module has been turned on by the correct wake-up voltage on the DX BUS. This value should be almost the same as the value of Power On Cycles and Power Off Cycles.

If Power Cycles is much higher than the other two, it may indicate
- A module frequently being disconnected from the DX BUS while the battery is still connected. This may cause a small voltage spike on the DX BUS that wakes up the Power Module while the Master Remote is still off.
- A problem with the DX BUS, for example an intermittent contact between the CANH line and Battery positive. Check the DX BUS cables and connections for damage, and replace the DX BUS cables if necessary.

4.3.2.5 Power On Cycles

The total number of times that the Power Module has completed the power-up sequence successfully.

4.3.2.6 Power Off Cycles

The number of times that the Power Module has completed the power-down sequence successfully after the DX System was turned off with the on/off button.

If this number is much lower than the Power On Cycles value, it may indicate an intermittent problem with the battery connection or users disconnecting the battery without turning the system off first. If the battery power is lost, the Power Module cannot perform a power-down sequence, while it will perform a power-up sequence the next time that the system is turned back on.
4.3.3 Battery Data

The battery history can help the person who performs maintenance on the chair to analyse the usage of the chair and the state of the battery.

Reset these values to zero when the battery is replaced.

4.3.3.1 Battery Capacity History

- Battery Time 75-100 % Capacity
- Battery Time 50-75% Capacity
- Battery Time 25-50 % Capacity
- Battery Time 0-25 % Capacity

These four parameters show the total elapsed time that the battery capacity has been at a certain level while the DX System has been turned on. These parameters together give an indication of how the battery and the chair have been used.

For example, if the battery has been at less than 50 % capacity for most of the time, it may indicate a battery with a bad cell, or a charger that is too light for the type of battery (it takes too long to charge the battery), or a user who never leaves the charger in long enough to charge the battery completely. In either case, it may be necessary to replace the battery.

**Note:**

If the battery has just been charged and the DX System is turned on, the battery capacity history is only updated after a drive cycle is completed.

No drive cycle is required if the battery has not been charged.

4.3.3.2 Overcharge Cycles

The number of times that the battery voltage has been higher than the High Voltage Warning* value for a long continuous period. The higher the battery voltage, the shorter the time before a cycle is counted. Only overcharge cycles that occur while the DX System is turned on are counted.

Many overcharge cycles may indicate a bad battery connection, or a battery with a bad cell, or a defective charger.

*Normally High Voltage Warning has the value of 29 V. Create a diagnostic report (see section 3.11) to check the actual value for the selected battery type.
4.3.3.3 Overcharge Time

The total time that the battery voltage has been higher than the **High Voltage Warning** value. Only overcharge time that occurs **while the DX System is turned on** is counted.

**Note:**

*If there are many overcharge cycles while there is not much overcharge time, the overcharging could be drive related: the user may go uphill and downhill often. If there is much overcharge time but not many overcharge cycles, the overcharging could be charger related: the charger used may actually overcharge the battery.*

4.3.3.4 Charge Time

The time during which the battery has been charged with several Amperes **while the DX System was turned on**.

Normally this value should be very low, because charging of the battery usually takes place while the system is turned off. If this value is high, it may indicate that:

- The user charges the battery while the system is turned on. This may cause problems if the user operates the actuators during charging, and the charger that is used is not able to cope with a load while charging. Some chargers interpret the decreased battery voltage during the operation of the actuators as the battery being not full yet, and as a result overcharge the battery, which decreases the life span of the battery.
- The chair frequently drives downhill with a fully charged battery. This may also cause overcharging of the battery.

4.3.3.5 High-load Discharge Time

The total amount of time during which the chair was used in high-load situations, such as driving up a ramp, driving up a hill, or driving on thick carpet. If this value is greater than 30% of the total drive time, the battery may be too small for the application.
5 Troubleshooting

5.1 Controller not detected

- Check that the controller is actually on.
- A communication error may have occurred: turn the controller off and back on.
- Check that you use the correct adaptor (1.2.3).
- DX / Rhino: check that you connect to the correct Hirose programming socket and not the XLR charger socket. DX / Rhino systems do not use an adaptor.
- Check that the software of the USB to COM converter is installed correctly (2.1).
- Check that the COM port that the Wizard uses (2.6) is the same COM port that the USB converter cable uses (2.1.1).
- Controller may be faulty: connect Wizard to another identical controller to check.
- PC/Cable/Adaptor may be faulty: connect controller to another PC/cable/adaptor.

5.2 Not able to read from controller

The Wizard is connected to the controller, but it is not possible to read from the controller, or the program is not shown on the screen.

- Your Wizard version or databases may not support the connected controller. Update the Wizard (2.7).
- The controller may have a software fault. Create a diagnostics report of the controller (3.11).

5.3 Not able to write to controller

If the read button is green and the write button still does not become red:

The Wizard needs a dongle to program a controller. Without a dongle, it is still possible to read a program from a controller or to create a diagnostic report, but it is not possible to write anything to a controller.

- Check that a program is actually loaded.
- Check that the dongle is connected to the computer.
- Was the dongle connected before the Wizard was started? If not, restart the Wizard.
- Check that the dongle is detected: Help → About, Dongle ID should not be zero.
- If the dongle ID is zero, download and install the latest full Wizard version from the website. The installer contains the correct dongle drivers. Do not use the internet update feature inside the Wizard to perform the update, because the internet update only updates the Wizard itself and the controller databases, not the dongle drivers.
Dynamic Controls is the world’s leading manufacturer of electronic controls for power wheelchairs and scooters. DYNAMIC was established in 1972 and is headquartered in New Zealand. Regional centres are located in Europe, United States, Asia, and Australasia.

ISO 13485 certified – DYNAMIC goes above and beyond industry standard expectations to ensure customers receive the best products possible.